Battery camera won’t connect to Google WiFi

Using google wifi (mesh) with 2.4 and 5ghz networks. The camera fails to connect after 30 seconds.

Any ideas?

I had a similar experience with mine. It’s best to keep it close to the Modem, verify your SSID and password. Here is a tutorial I got from this link: https://www.colourmyliving.com/home/vacos-cam-review-wireless-ai-powered-security-camera-with-full-colour-night-vision/#setup

Step-by-Step Instructions to Get Vacos Cam Connected to the Home Network

The steps to getting your camera connected to your home WiFi are as follows:

IMPORTANT : The camera only works with 2.4GHz network. For setup, have the camera located as close as possible to the home router. Another point to consider is that the smartphone with the Vacos app needs to be on the same 2.4GHz network.

Vacos App Welcome Screen and Add Device Button

  1. Press the reset button behind the camera briefly. This will switch on the camera and go straight into setup mode indicated by a voice prompt and flashing LED. If the camera does not respond, reset the camera by holding down the reset button for 3 seconds. Again, a voice prompt will let you know that the camera is resetting and re-entering setup. If you do not hear anything, chances are, the camera’s battery is flat. Charge the camera up and attempt again.
  2. On the Vacos app, tap on Add Device > Battery Cam
  3. Confirm that you have turned on setup mode by ticking the checkbox and clicking the “ I Know ” button.
  4. You will then be asked for your WiFi password . Make sure that your phone is on the same 2.4GHz WiFi network you intend to use for the camera. You can double check this by looking at the WiFi name field. Enter the password for this network, then click Next .
  5. A QR code will present on your phone, hold this up in front of the camera between 10-20 cm away.
  6. You will know when the camera has successfully scanned the code and connected to the WiFi with another voice prompt. This is where our first attempt fell over. We were successful on the second attempt.
  7. On the phone, tap Scan succeeded and the camera will be added to the app. The first thing it will ask for is a name for the camera. Use a custom name or select one of the preset names (Kitchen, Bedroom, Living room, Lobby, Yard) then click OK .
  8. The app then goes to the dashboard. You can click on the preview video thumbnail to access Live view.

As soon as we successfully connected the camera, the app showed that the camera’s firmware needed updating. Apply this update as long as you know there is enough charge in the camera or ensure that it is wired up to an adapter then perform the update. Here is a video tutorial on how to setup the camera and a quick operation guide.

Yeah I figured it out. On my iPhone it fails but on my android test device it worked. I’ve hit this problem before with google WiFi and iOS, usually there is a fix they can make to help the process work. Something about how iOS hands off the WiFi to the device vs Android.

Some Wyze devices I’ve tried hit the same issue.