Firmware update

I am having trouble updating the latest firmware.

I have taken off the camera and placed it on its charger and next to my router. I press the update in the app and it says please don’t power down the app whilst it’s updating. It stays in this mode for some time.

Is there a way that you embed the firmware updates as part of the app build rather than trying to do this manually within the app when an update is made?

I set mine to update and it kept acting like it wanted to. I haven’t had any notifications and checked-the camera is offline. Anyone else having issues with the process? I’m going to bring it in and plug it in, see if I can get it back on track.

Same here - no idea if it’s updated or not as there’s no obvious way to check the current version. Seems to hang on processing the update.

However, something has changed:
The vcr playback is smoother,
But I can no longer switch off the status led, and the live feed defaults to SD after changing it to HD

Hi Guys,

Thanks for your feedback :slight_smile:
When the firmware upgrade gets stuck, please follow below procedures to troubleshoot:

  1. Put the camera next to your WiFi router.
  2. Connect the camera to a power adapter.
  3. Check if the status led on the camera is still on (When it’s off, that means the camera is sleeping and the upgrade will fail)
  4. Check if your camera’s current version is 3.6.9. (Route to check the firmware version: Live video scrren–Settings–Firmware update)

Let me know your feedback and I will help further.

Hello

I have tried the below steps without any luck. It seems to just stay in the upgrade mode with the wheel going around in circles.

Whilst I’m trying to upgrade I have it connected to a power source and next to my router.

The version of the firmware is 3.6.9

I’ve tried that, all weekend, in fact. Still hanging at 6.9. I had to plug it in because the first time I just put it back outside it went nearly dead overnight. Kept it inside, plugged in, placed either 1’ away or 8’ away while plugged in, and kept going back to the app trying to make the update happen. Put it out last night and the battery still shows full, so that’s good, but still trying again to update firmware.

Hi @Aston_Seymour and @rcworship,

Thanks for your feedback.

Actually we have one user who met the same issue and resolved it. Here is the method tried:
I had to remove the camera so and reset, the firmware update was hanging in the app so i had to delete the app and reinstall. And repeat the process.
Would you try it as well?

I have already done this across 3 cameras and I’m unable to even reconnect back to my wifi.

All 3 cameras were working however due to the battery drain I had to bring them in for a recharge. As I did this all cameras went offline so I removed them and reinstated them. Now only 1 of my 3 cameras is online. The other two cameras I can’t log them into my wifi. This is being tracked as an issue on another ticket.

The one camera that is working I have tried to do the firmware update as you have instructed and I am unable to load it.

Im still not having luck with this. I have been very patient with the process and trying it every other day however this is getting beyond a joke now.

Can someone please help me get my firmware installed?

Hi @Aston_Seymour, stupid question, did you try to reset the camera and start from scratch? Perhaps try from a different device (iPhone/Android)
I was able to update the firmware without hassles, actually the camera was quite far from the router.
I have reset several times the camera for checking with different wireless connections and generally all good!

Yes cameras have been done from scratch although now none of my cameras can join my wifi. These were working just last week.

How long does the firmware update take?

Just few minutes! I’m surprised how these cameras are performing differently between users, mine is working fine, but according to many people there are issues with setup, networking, recording, playback, firmware update and so on.
Your can try to consume the battery, hard to say how if you don’t have access, and once the battery is empty fully charge it and start over again. Give it a try and let me know!

Tim responded to my support email With information that deleting the app helped fixing the firmware hang up Issue. I deleted and reinstalled, then brought the camera right next to the router and it updated with no trouble, in no time. Seems to be working well now and haven’t had any issues with the battery life since the first night she apparently tried all night to update.

Here are my steps as followed

  1. Delete the app and reinstall
  2. Plug the device in to power it
  3. Add the device and connect to my wifi.
  4. Unable to connect to my wifi. I have a dual band router and cannot connect to it. I have also tried to remove the 5ghz signal to only use the 2.4ghz signal but no luck here either. I get the message Internet connection failure

So none of the 3 cameras I have are not able to connect to my wifi. All 3 cameras previously were working however due to the battery drain in the firmware edition I restarted all of them as I wasn’t able to get the firmware update working.

Overall pretty disappointed as I have spent hours and hours troubleshooting.

Hi Aston,

Thanks for your detailed feedback :slight_smile:
The steps you have tried are okay. As the 3 cameras used to work with your WiFi network before, could you also check if anything has changed on the WiFi network? For example:

  1. Has the name of your WiFi network (the SSID) or password been updated?
  2. Has other devices been added to the same WiFi network? (In case there were already several of them so the cameras cannot join in)

Hello

The name of my network hasn’t changed and my credentials have not changed either whilst I was troubleshooting.

After going back and fourth on setup I didn’t have any luck. I did test a deliberate test in making a typo in my password and it did recognise thy is by saying ‘invalid password’. So it I switched it back to the correct password but still no change.

Since the above after days of troubleshooting I have changed my network name and password to something more simpler but still no luck getting the cameras on my network.

All 3 cameras now say ‘initialising setup please wait ‘ constantly which is very annoying.

Hello @Aston_Seymour,

Not sure if this will help. I do not have this camera yet but i did find this:

Step-by-Step Instructions to Get Vacos Cam Connected to the Home Network

The steps to getting your camera connected to your home WiFi are as follows:

IMPORTANT : The camera only works with 2.4GHz network. For setup, have the camera located as close as possible to the home router. Another point to consider is that the smartphone with the Vacos app needs to be on the same 2.4GHz network.

Vacos App Welcome Screen and Add Device Button

  1. Press the reset button behind the camera briefly. This will switch on the camera and go straight into setup mode indicated by a voice prompt and flashing LED. If the camera does not respond, reset the camera by holding down the reset button for 3 seconds. Again, a voice prompt will let you know that the camera is resetting and re-entering setup. If you do not hear anything, chances are, the camera’s battery is flat. Charge the camera up and attempt again.
  2. On the Vacos app, tap on Add Device > Battery Cam
  3. Confirm that you have turned on setup mode by ticking the checkbox and clicking the “ I Know ” button.
  4. You will then be asked for your WiFi password . Make sure that your phone is on the same 2.4GHz WiFi network you intend to use for the camera. You can double check this by looking at the WiFi name field. Enter the password for this network, then click Next .
  5. A QR code will present on your phone, hold this up in front of the camera between 10-20 cm away.
  6. You will know when the camera has successfully scanned the code and connected to the WiFi with another voice prompt. This is where our first attempt fell over. We were successful on the second attempt.
  7. On the phone, tap Scan succeeded and the camera will be added to the app. The first thing it will ask for is a name for the camera. Use a custom name or select one of the preset names (Kitchen, Bedroom, Living room, Lobby, Yard) then click OK .
  8. The app then goes to the dashboard. You can click on the preview video thumbnail to access Live view.

As soon as we successfully connected the camera, the app showed that the camera’s firmware needed updating. Apply this update as long as you know there is enough charge in the camera or ensure that it is wired up to an adapter then perform the update. Here is a video tutorial on how to setup the camera and a quick operation guide.

You can find a more detailed write up on this camera and what I shared at this link below…/

1 Like